+ Reply to Thread
Results 1 to 2 of 2

Thread: Crown CSL 1400

  1. #1
    Senior Member
    Join Date
    Jul 2006
    Location
    Kansas City
    Posts
    101

    Crown CSL 1400

    Channel one has very bad distortion. I have rulled out the input section of the amplifier by swaping the circuitry around. Channel 2 was rebuilt about a year ago. The trasisters on CH1 apear to be original. Could a bad BJT make that distortion. Also I noticed ch1 side of the chassis was extremly HOT after its failure. I took a DC reading across ch1 output and it was around one volt. Can someone point me in the right direction?

  2. #2
    Senior Member BMWCCA's Avatar
    Join Date
    Feb 2006
    Location
    Virginia
    Posts
    5,343
    ". . . as you have no doubt noticed, no one told the 4345 that it can't work correctly so it does anyway."—Greg Timbers

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Crown Vs. Crown..The China Syndrome !
    By jeenie67 in forum Professional Amps
    Replies: 30
    Last Post: 05-27-2011, 07:22 PM
  2. Array 1400 help
    By jasonyeo in forum Lansing Product General Information
    Replies: 6
    Last Post: 10-29-2010, 08:00 AM
  3. Crown XTI1000 bridged or Crown XLS602D stereo
    By jonfu@ymail.com in forum Professional Amps
    Replies: 8
    Last Post: 07-02-2009, 09:45 AM
  4. 1400 Nd
    By jim henderson in forum Lansing Product General Information
    Replies: 32
    Last Post: 12-02-2004, 03:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts