Results 1 to 9 of 9

Thread: L100 help

  1. #1
    tailsandfeather
    Guest

    L100 help

    hello, all, newbie here with a question. I did a general seach and could not find any info so forgive me if I am rehashing anything here.
    My father in law gave me a set of L100's, he bought a Bose system and no longer needed the JBL's. Anyway, they have a loud pop noise that occurs whenever the volume is up a little. I have the same setup, receiver, eq etc....that I had with my previous speakers that had no pop noise. Now I am no expert and hope to learn from this board that I just found today. Any help directing me toward the right person or repair facililty would be appreciated. I know that I have not given much info, so any questions that could be asked that I may be able to answer that would help me would also be appreciated. Hope I have not confused anyone.
    Thanks in advance,
    Mike

  2. #2
    Senior Member Audiobeer's Avatar
    Join Date
    Apr 2003
    Location
    St. Peters, Mo just west of St. Louis.
    Posts
    2,402
    The question I have to ask first is this, You mention a pop in the L-100s hooked up to one system. Do the L-100s do the same thing when hooked up to an all together different system?

  3. #3
    tailsandfeather
    Guest
    unfortunately I do not have another system handy to hook them up to. Would that be the first step? I could always lug them to a friends house and do that

  4. #4
    Senior Member Audiobeer's Avatar
    Join Date
    Apr 2003
    Location
    St. Peters, Mo just west of St. Louis.
    Posts
    2,402
    I would definitely borrow someones reciever first and run another source through the L100s before I would do anything else. If you no longer have the problem then It's safe to say it isn't the L100s. I have found that a violent popping noise will come from the source more often than the the speaker. I had a Marantz reciever that use to do that. If you turned it up it would make a popping noise that was intolerable and almost damage my speakers. Let us know!

  5. #5
    Senior Member GordonW's Avatar
    Join Date
    May 2003
    Location
    Marietta/Moultrie GA USA
    Posts
    1,457
    Couple of things:

    First, you mention EQ... the L100 has PRODIGIOUS bass output compared to many speakers of similar size, so it may not need the same EQ curve (usually doesn't want bass boost, whatsoever) as the old speaker. If you're over-driving the woofer with EQ, it might help to 'zero' the EQ and start over(start from flat, and only change a few things, cutting rather than boosting to remove 'harshness' and such rather than trying to 'jack up' holes)...

    Also, it's possible, that you may be dealing with a woofer in the L100, that has the spider starting to rip loose from the voice coil at the backside of the cone/voice coil joint. The good thing, is that if you catch it EARLY (ie, before it COMPLETELY comes loose), you can usually have a repair tech re-glue the spider to the cone and voice coil, and the driver will be saved. I've fixed a LOT of these things for people, over the years, that had this problem... if this turns out to be the case, I'd be glad to fix 'em, if you like... it's not an expensive repair...

    Regards,
    Gordon.

  6. #6
    hector.murray
    Guest

    Catch em quick!!!

    I just recieved a pair that weren't as fortunate. The cone seperated from the VC and sheared the wires. so check em out!
    Gordon, want a slightly abused pair of VCs? I'll make you a real good deal on 'em.

  7. #7
    hector.murray
    Guest

    Glue

    What glue would you use to effect this repair if the drivers weren't already shot?

  8. #8
    Senior Seņor boputnam's Avatar
    Join Date
    Apr 2003
    Location
    northern california
    Posts
    7,009

    My FAVORITE speaker!!


    Quote Originally Posted by tailsandfeather
    ...they have a loud pop noise that occurs whenever the volume is up a little.
    I'm late to the party here, but...

    1) Does this "pop" come from both channels?
    2) Does it come only from the woofer? Is it frequency dependant?
    3) Is it only on say, a kick drum sound (or abrupt transients)?
    4) Try rotating the L-pad knobs - is there a scratchy sound?

    GordonW is giving good ideas, but maybe you can describe the symptoms and conditions in better detail for us.
    bo

    "Indeed, not!!"

  9. #9
    Senior Member GordonW's Avatar
    Join Date
    May 2003
    Location
    Marietta/Moultrie GA USA
    Posts
    1,457
    Quote Originally Posted by hector.murray
    I just recieved a pair that weren't as fortunate. The cone seperated from the VC and sheared the wires. so check em out!
    Gordon, want a slightly abused pair of VCs? I'll make you a real good deal on 'em.
    How are the cones themselves? If they're not ripped, I could definitely re-use them! Just carefully cut out the fabric surround, leave the remnants on the cone...

    As for glue- 5 minute epoxy works great. Just be careful to JUST put what you NEED on there, and not more... you just don't want it leaking down into the voice coil. I usually turn the driver ON ITS FACE to cure, so that if it runs anywhere, it'll run onto the backside of the cone. No harm there...

    Regards,
    Gordon.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. L100 and 43XX Monitor Legacy
    By Don McRitchie in forum Lansing Product General Information
    Replies: 8
    Last Post: 05-22-2012, 08:09 AM
  2. Just receive my JBL L100... with LE26 ?!
    By fraula in forum Lansing Product General Information
    Replies: 20
    Last Post: 02-04-2005, 12:19 PM
  3. L100 - Which Way is UP?
    By wally44 in forum Lansing Product Technical Help
    Replies: 3
    Last Post: 01-23-2005, 10:39 PM
  4. mod to L100
    By Donald in forum Lansing Product Technical Help
    Replies: 1
    Last Post: 09-01-2004, 06:50 AM
  5. 88 PLUS 12 - RARE or just another L100?
    By L88P in forum Lansing Product General Information
    Replies: 1
    Last Post: 11-14-2003, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •