Results 1 to 15 of 18

Thread: What happened??

Hybrid View

  1. #1
    Senior Member BMWCCA's Avatar
    Join Date
    Feb 2006
    Location
    Virginia
    Posts
    6,964

    What happened??

    Last night the forum link produced only an error message:

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MST/-7.0/no DST' instead in ..../includes/class_core.php on line 1129

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Denver' for 'MST/-7.0/no DST' instead in ..../includes/class_core.php on line 1130
    Now we have an "activity" page instead of the normal "what's new" listing of active threads.
    And Wagner can't edit his posts . . . .

    Did something break?

    Thanks for everything you do and don't take this as a complaint. Just trying to figure out what's happening!
    ". . . as you have no doubt noticed, no one told the 4345 that it can't work correctly so it does anyway."—Greg Timbers

  2. #2
    Webmaster Don McRitchie's Avatar
    Join Date
    Apr 2003
    Location
    Winnipeg, Canada
    Posts
    2,045
    Nothing is broken to my knowledge. We've been running an older version of vBulletin that had serious security risks. I became aware of this risk on Friday and the fact that it was being reported that hackers were now employing bots to scan for sites running non current vBulletin installations as a means of taking over the servers running them. I attempted an update on Friday to a fully secure version, but was unsuccessful due to version conflicts with underlying software.

    I corresponded with John Nebel on this and he stated the version issue can not be rectified in the short term and that the forum could go back to the old version until a workaround was developed. John runs security software on his servers that he states should provide adequate protection for now. As a result, I restored the old forum and turned it back on late Friday.

    On Sunday, John informed me that only the most recent version of vBulletin has the version conflict. The immediately prior version (newer than what we were running) is considered secure for now and it was worthwhile updating to that. Thus, on Sunday evening, I attempted that update. I was successful in uploading all of the new files which overwrote the old files and caused the error messages everyone saw. This was an expected temporary condition that was expected to be rectified once the installation program was run to set up the new version.

    This is where things went south, but in a good way. John's IPS (Intrusion Protection System) was so effective it locked me out twice, even though John was revising its rules in a way that should have allowed me access. I was unable to either run the install program or revert back to the old version. Time ran out Sunday evening to do anything further until today, when John could set up Virtual Private Network access for me to get around the IPS.

    That was the plan until Ann Cantlow came to the rescue this morning. John offered Ann's services to run the installation program locally and Ann was able to get it successfully installed after one minor installation glitch.

    So now we have an updated forum with new and untested features. I'll do what I can to see if its possible to change settings to the operate as closely as possible to the old forum. Personally, I do not like my home page being the new Activity Page and I will look to put an end to that. I'll also look into the editing settings. If anyone is finding other irksome changes in forum behaviour, post them here, and I'll see what I can do.

    To close, we should be good on security for the next short while. However, it's a given that security flaws will eventually be found in this version, requiring further updates and thus dealing with the version issue with underlying software. This will likely not be an easy fix and could have significant repercussions on the overall site. It will be worked out, but I'm not sure how just yet.
    Regards

    Don McRitchie

  3. #3
    Senior Member grumpy's Avatar
    Join Date
    Oct 2003
    Location
    SoCal
    Posts
    5,338
    Thanks Don, John, Ann!
    Should be interesting for a few days

  4. #4
    Administrator Mr. Widget's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco
    Posts
    9,981
    Quote Originally Posted by grumpy View Post
    Thanks Don, John, Ann!
    Should be interesting for a few days
    Absolutely! Thank you guys and gal.


    Widget

  5. #5
    Senior Member Ed Zeppeli's Avatar
    Join Date
    Dec 2007
    Location
    Nanaimo, BC
    Posts
    608
    Quote Originally Posted by Don McRitchie View Post
    I'll also look into the editing settings. If anyone is finding other irksome changes in forum behaviour, post them here, and I'll see what I can do.

    To close, we should be good on security for the next short while. However, it's a given that security flaws will eventually be found in this version, requiring further updates and thus dealing with the version issue with underlying software. This will likely not be an easy fix and could have significant repercussions on the overall site. It will be worked out, but I'm not sure how just yet.
    Thanks for the update on the update!

    Others may have differing views on this but on other forums I've come to appreciate the 'like' or 'thanks' feature as a quick way of showing that a post has value to me. (Without necessarily responding to the thread)

    If the new software has this feature it would be nice to have it enabled if possible.

    Thanks again,

    Warren
    DIY Array, 2242 sub, 4408, 4208, Control 8SR, E120 Guitar cab, Control 1, LSR305.

  6. #6
    Senior Member
    Join Date
    Oct 2003
    Location
    Texas
    Posts
    1,732
    One thing I noticed.

    I went to my profile page by clicking on my user name at the top. Then clicked on "Find Latest Posts" to see if all recent posts made the journey. On that page, and it's the only place I've noticed it, along the top in the gray area is this:

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39

  7. #7
    Heather [Senorita member] hjames's Avatar
    Join Date
    Nov 2005
    Location
    NoVA - DC 'burbs
    Posts
    8,341
    I'm seeing that error all over the place - hit "New Posts" or do a Search, or most any function with the database ...



    Quote Originally Posted by JeffW View Post
    One thing I noticed.

    I went to my profile page by clicking on my user name at the top. Then clicked on "Find Latest Posts" to see if all recent posts made the journey. On that page, and it's the only place I've noticed it, along the top in the gray area is this:

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39

    Warning: Only variables should be passed by reference in ..../includes/class_bootstrap.php(561) : eval()'d code on line 39
    Test edit, many hours later - now works!
    2ch: Oppo, JoLida 502CRC, JBL L212, 18ti,240ti; Heath AS101, Von Schweikert VR4
    7.1: Oppo BDP103D, B&K, UREI 809A, JBL B460

  8. #8
    Senior Member
    Join Date
    Oct 2003
    Location
    Texas
    Posts
    1,732
    At least it's not just me, then.

  9. #9
    Senior Member
    Join Date
    Apr 2012
    Location
    Houston
    Posts
    760
    I enjoy this community so much I can endure some software quirks.


    Thank for keeping us in the loop though and all the good work.


    Nick

  10. #10
    Senior Member SEAWOLF97's Avatar
    Join Date
    Jan 2006
    Location
    PDX, ®egon
    Posts
    9,104
    the "new posts" button moves position in different screens.
    “If you think that’s the dumbest thing you’ve ever heard,
    just wait a couple minutes!”

  11. #11
    Heather [Senorita member] hjames's Avatar
    Join Date
    Nov 2005
    Location
    NoVA - DC 'burbs
    Posts
    8,341
    Thank you all for kicking in so quickly to pick things back up, and for security updates - much needed.

    Don't know if you know, but another forum, AudioKarma, recently decided vBulletin had too many security issues,
    felt the newer versions were not as well supported as they had been in the past, and was just getting long in the tooth.

    So they opted to go through the (huge hassle) of migrating their site to a newer software called XenForo.
    It has been a HUGE undertaking, and lo, there has been great gnashing of the teeth (because it is different!!)

    But I gather the final product is easier on the database, and as a user, it (usually) feels faster -
    and they seem to be a much bigger site than LHS (no flames meant).

    I gather it was a big deal for the management - they are STILL fine tuning some of it ...
    but any kind of forum software change would be a huge process.

    Again, thanks for keep our data safe!
    2ch: Oppo, JoLida 502CRC, JBL L212, 18ti,240ti; Heath AS101, Von Schweikert VR4
    7.1: Oppo BDP103D, B&K, UREI 809A, JBL B460

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What ever happened to....
    By RIGGED in forum Lansing Product General Information
    Replies: 9
    Last Post: 08-03-2008, 09:35 AM
  2. What happened?
    By pangea in forum Lansing Product General Information
    Replies: 14
    Last Post: 03-12-2007, 04:43 PM
  3. What has happened here ????
    By LE15-Thumper in forum Forum Feedback
    Replies: 20
    Last Post: 06-02-2005, 09:03 PM
  4. What Happened?!
    By Mr. Widget in forum General Audio Discussion
    Replies: 23
    Last Post: 01-19-2005, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •