Results 1 to 5 of 5

Thread: Dayton plate amp trouble

  1. #1
    Senior Member
    Join Date
    May 2008
    Location
    Westchester NY
    Posts
    1,134

    Dayton plate amp trouble

    This 1,000W plate amp has been running my 15" sub for a few years now and I like it. Lately, it has been cutting out periodically. I checked all the wires and connections which are OK.

    Now it does not want to run at all.

    I think it is a Class A/B, amp....

    Are these amps junk, or is it worth fixing?

  2. #2
    Administrator Mr. Widget's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco
    Posts
    9,865
    Why not contact PE and ask if they recommend repair or replacement. They should know how well they hold up and whether or not they are worth fixing.


    Widget

  3. #3
    Administrator Robh3606's Avatar
    Join Date
    Apr 2003
    Location
    Rocinante
    Posts
    7,950
    FWIW I have used a pair of their plate amps for about 10 years now. Still going strong.

    Rob
    "I could be arguing in my spare time"

  4. #4
    Senior Member
    Join Date
    May 2008
    Location
    Westchester NY
    Posts
    1,134
    I took it in to a local TV repair shop. He said it sounds like it might be a bad cap....

    the unit used to cut in and out for about 6 months.,.... now it will not kick in at all.....

    UHG!

  5. #5
    Senior Member
    Join Date
    May 2008
    Location
    Westchester NY
    Posts
    1,134
    ...local repair shop said it is a bad transformer - part is $200!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I'm in BIG trouble!
    By windsor202 in forum Lansing Product Technical Help
    Replies: 6
    Last Post: 01-21-2013, 07:16 AM
  2. LE15 trouble- need help
    By tomtep in forum Lansing Product Technical Help
    Replies: 6
    Last Post: 07-23-2009, 09:09 PM
  3. New Dayton class G amp- POW!
    By robertbartsch in forum Professional Amps
    Replies: 12
    Last Post: 09-27-2008, 03:52 PM
  4. Trouble with my BX63, I think.
    By still4given in forum Lansing Product Technical Help
    Replies: 4
    Last Post: 10-15-2004, 08:14 PM
  5. Dayton Capacitor Questions
    By cary in forum Lansing Product Technical Help
    Replies: 2
    Last Post: 07-25-2003, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •