Results 1 to 2 of 2

Thread: Altec 602A Horn Repair

  1. #1
    Junior Member
    Join Date
    Oct 2012
    Location
    Michigan
    Posts
    7

    Altec 602A Horn Repair

    I have a pair of the 602 speakers. Both horns function on the pair. Problem is when in shipping the horn from one of the speakers became unglued/disconnected at the base. What type of glue/epoxy can be used to mount the horn back to the driver portion? They are going in a pair of 612 cabinets. Has anyone used the 602 in the 612 cabinets?

  2. #2
    Member theophile's Avatar
    Join Date
    Oct 2005
    Location
    Sunshine Coast Australia
    Posts
    30
    Ask your question here:

    http://www.hostboard.com/forums/f700...ers-board.html

    There is no shunning of Altec questions on that board.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Altec 601 HF need repair
    By Aronier in forum Lansing Product Technical Help
    Replies: 4
    Last Post: 07-08-2009, 10:45 AM
  2. Altec 601c needs repair
    By audioquest in forum General Audio Discussion
    Replies: 2
    Last Post: 06-08-2009, 02:38 PM
  3. HELP ME! I want repair my old ALTEC NINE
    By endigy in forum Lansing Product General Information
    Replies: 2
    Last Post: 01-22-2009, 10:17 AM
  4. Altec 515B Repair Help
    By josh in forum Lansing Product Technical Help
    Replies: 0
    Last Post: 03-28-2007, 04:29 PM
  5. Altec 416 repair
    By John in forum Lansing Product Technical Help
    Replies: 0
    Last Post: 06-27-2004, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •