+ Reply to Thread
Results 1 to 5 of 5

Thread: Altec 802/511 driver element issues...

  1. #1
    Senior Member GordonW's Avatar
    Join Date
    May 2003
    Location
    Marietta/Moultrie GA USA
    Posts
    1,454

    Altec 802/511 driver element issues...

    Hey, I've got a guy here, who had me repair an Altec 802/511 from a vintage A7 (green horn, 16 ohms)... came in with a dead element.

    Well, it gets interesting... the first element we put in (we used a Radian element, which seemed to get good comments wherever I looked), went open-circuit within two weeks of installation. We got a second element, and it seemed to be OK-- but now (several months later) the customer called back, and said that it was buzzing and crackling... the same one. The other speaker still has its original element, in good shape, so I don't think he's overly abusing them...

    Apart from the usual ancillary issues (amplifier oscillation problems on one problem, etc), can anyone tell me how subject the Altec A7 crossovers are to cap shorts and such? I've seen people blow caps to bits, but that's usually obvious- if it looks like the aftermath of lighting a bunch of ladyfingers, then... . But this- everything LOOKS OK, and even SOUNDS OK when a good element is installed... it just seems to eat elements.

    Or, am I possibly dealing with a mechanical issue? Alignment, torque, etc?

    Any clues? Any issues with Radian elements? Anything better I should be looking at?

    Thanks!

    Regards,
    Gordon.

  2. #2
    Administrator Mr. Widget's Avatar
    Join Date
    Apr 2003
    Location
    San Francisco
    Posts
    8,274
    Try Bill at Great Plains Audio.

    http://www.greatplainsaudio.com/

  3. #3
    Member Todd W. White's Avatar
    Join Date
    Apr 2003
    Location
    Sapulpa, Oklahoma
    Posts
    92
    I agree - the Radian Diaphragm/Voice Coil Assemblies are just not capable of handling what this guy is doing to them - plus they don't sound NEAR as good as the ones you'll get from Bill@ Great Plains Audio!

    Go to his website, and you'll know what I mean...

    In all reality, I would suspect that this guy is beating the diaphragms to death with a clipping solid state amplifier.

    Abuse is the #1 reason ALL diaphragms fail!

    You should send the entire unit (preferably BOTH) in to GPA for a complete rebuild. For the price of the diaphragm, Bill will replace it AND remagnetize the driver motor, which is the #2 reason why diaphragms fail - the Alnico V magent has lost some of it's "umph", and can't keep up with the amplifier.

    The woofers prbably need help, too.

    I should think the crossovers are fine...

    Go to GPA and ask for the PASCALITE diaphragms for this driver - their greater power handling might allow them to hold up, once they've been rebuilt.

    BUT - find out what kind of music he's listening to, and what equipment he's using!

    I sure hope he's not trying to play his guitar through them like one customer I had was several years ago....
    Todd W. White, Owner & Webmaster
    Altec Lansing's (unofficial) Homepage
    http://alteclansingunofficial.nlenet.net/

  4. #4
    Junior Member
    Join Date
    Apr 2003
    Location
    Cape Cod, Massachusetts
    Posts
    5
    Todd, being a guitar player I am curious why it's not a good idea to play guitar through them. Why can't they take it? Or is it simply the excesses of some (not moi) guitar players?

  5. #5
    Senior Member Tom Brennan's Avatar
    Join Date
    May 2003
    Location
    Chicago
    Posts
    676
    Tom Danley of ServoDrive says that Radians don't hold up well under prosound use. He admired the performence of the Radians but switched to B&C drivers for reliability.

    IME, when used for hi-fi, Radian diaphragms in Altec drivers are reliable and sound every bit as good as original Altec aluminum diaphragms.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Altec Lansing 1594b Output driver
    By joey1355 in forum Lansing Product Technical Help
    Replies: 0
    Last Post: 11-02-2004, 05:18 PM
  2. Altec 811b + what driver?
    By Al Klappenberge in forum Lansing Product Technical Help
    Replies: 20
    Last Post: 02-03-2004, 09:35 AM
  3. Altec 288-8K driver
    By cope in forum Lansing Product Technical Help
    Replies: 5
    Last Post: 10-05-2003, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts