PDA

View Full Version : Altec Lansing Model 6 Crossover Removal



herkimer
04-24-2016, 08:24 PM
Good Evening All,
I have a set of Altec Lansing Model 6's that need the midrange level controls cleaned. Can someone tell me how to remove the assembly from the speaker cabinet for access to the controls? I am not sure and would rather not break anything. Thanks so much in advance. Randy

gdmoore28
04-25-2016, 10:50 AM
I have zero experience with the Model 6, so I did a search and turned up - nothing. Is there a removable plate on the front of the crossover that might pop off and give access to the mounting screws? Does the back look to be removable? How about access thru the woofer cutout?

GeeDeeEmm

herkimer
04-25-2016, 05:14 PM
Hi and thanks so much for the reply. It's got a very similar setup like the model 14. It looks like the cover may just pop off to gain access to the mounting screws, but not sure. I took the woofer out and found a plastic housing surrounding the x-over assembly preventing access that way. Like you I Googled the problem and came up empty. I had messaged Great Plains Audio a couple of days ago but haven't gotten a reply. I was just afraid of breaking something but the controls are going to have to be cleaned. These were bought new in 1980 from an Altec Lansing dealer in San Francisco and they are special to me. Maybe someone will have the solution. Thanks again so much! Randy

Joseph Smith Jr
04-25-2016, 07:37 PM
Pull the level control knobs and see if the pots' nuts don't also secure the fascia (most likely) with that soft marterial baffle treatment

If not, pull a woofer and see if they don't fasten from the back, same as the horn

herkimer
04-25-2016, 08:53 PM
I wondered if taking those nuts off securing the pots might be holding it. I'll try that tomorrow and let you know. Thank you so much Joseph! Randy

voice of theatr
04-26-2016, 05:14 AM
There is almost no info about the Model 6's online. Any chance you could post a few photos? I own Model 14's, 19's, Santana II's, and used to own Model 9's and would love to see what those 6's look like--and I'm sure I'm not the only one!

Joseph Smith Jr
04-26-2016, 06:41 AM
There is almost no info about the Model 6's online. Any chance you could post a few photos? I own Model 14's, 19's, Santana II's, and used to own Model 9's and would love to see what those 6's look like--and I'm sure I'm not the only one!
It's everywhere including a lot of aftermarket parts, at least here at my place, including the library here at Lansing Heritage best deal in town I've found so far! :bouncy::

http://www.lansingheritage.org/html/altec/specs/home-speakers/model-4-6-8.htm
http://www.lansingheritage.org/images/altec/specs/home-systems/model-4-6-8/page15.jpg

gdmoore28
04-29-2016, 08:48 AM
I wondered if taking those nuts off securing the pots might be holding it. I'll try that tomorrow and let you know. Thank you so much Joseph! Randy

I'll bet that you and Joe have found the answer. The pics strongly indicate that the plate is held on by the nuts that secure the pots. However, both the port and the horn are apparently mounted the same way as the crossover/level controls, and there is definitely no nuts to remove there. While you had the woofer removed, did you happen to look for the means for mounting the port and horn lens?

Those are some nice looking Altecs. Will need to look into that line.

GeeDeeEmm