PDA

View Full Version : Altec 605A duplex help



JUGGERNAUTAUDIO
01-02-2009, 01:15 PM
Hi, im new to the forum. How is everybody?? Well i purchased a pair of altec lansing 605A duplex speakers the other day. I have been looking all over for some info on the peticular pair i have. The pair i have the red surrounds, witch i have heard are the older first series. The question i have is the crossovers are n-1600c and say 16 ohm, but when i ohm out the HF on the speaker they read 5.0 ohm. I thought the 605A's were 16 ohm speakers?? The LF is reading 11.1 ohm, so i know thats a 16 ohm diphram. I did take the HF cap off and looked at the diphram it has the Ll on the black plastic surround of the diphram. So has someone changed them or is it original? they look as no one ever touched them..any info on these speakers would be great.. Im adding some pictures, i also wanted to know if the red paint on the HF screw is some sort of tamper seal?? Thanks for all your help..

http://i476.photobucket.com/albums/rr129/AUDIOSELLER/DSC05282.jpg







http://i476.photobucket.com/albums/rr129/AUDIOSELLER/DSC05288.jpg

http://i476.photobucket.com/albums/rr129/AUDIOSELLER/DSC05271.jpg

tomp787
02-27-2009, 01:16 AM
Hello,

I think your 605a with red surrounds are reconed. Maybe they have a new HF diaphragm as well? I have 3 605a and one was reconed long ago with the same red surround.

Tom

Steve Schell
03-08-2009, 03:52 PM
Juggernaut, those red surrounds are typical of 605B drivers, but I'm not sure whether Altec switched to those surrounds before beginning 605B production.

The red paint is original, a tamper seal as you suspected. The stamping of "L1" on the diaphragm ring is typical of Altec diaphragms, so I would suspect that your diaphragms are original. Nice drivers.

TEXAMPS
07-03-2016, 07:04 PM
My 605A look the same and read the same ohm to your speakers.

I had same question: As my "crossovers are n-1600c and say 16 ohm, but when i ohm out the HF on the speaker they read 5.0 ohm. I thought the 605A's were 16 ohm speakers?? The LF is reading 11.1 ohm, so i know thats a 16 ohm diaphragm."

Tony

gdmoore28
07-04-2016, 05:28 AM
A quick search of "sold" 605As on ebay and photos on the web show lots of 605As with the red surrounds - probably a third of them. Unless there was a massive number of recones, I'll bet the red surrounds are original. Are there numbers on the back of the cones?

I couldn't find enough search results to make an educated guess on your HF diaphragm, though. Did the red paint on the screw show signs of having been broken before you opened them? Are there part numbers printed on the diaphragms?

I don't know if it relates to your situation, but extended reading here and on the Altec Users Board relates a number of instances where Altec used their 16 ohm crossovers with 8 ohm components.

GeeDeeEmm

TEXAMPS
07-13-2016, 09:21 PM
I am super new to Altec,

I know allot about everything Guitar, amp vintage, tubes, parts & caps. Even McIntosh & tube Marantz gear as I have owned & restored a bunch of it. I also have a major vintage parts stash & design, repair tube amps.

Funny though as I have never even had Altec on my radar before? I had taken a trip to Taiwan and found a crazy audio shop that had a killer Japanese book about vintage Altec that peaked my interest. Also recording the Beatles pushed me to grab a set of 605A. Anyway here I am.... Just need to find plans for the TV front Altec 614 cabs now.

Tony