PDA

View Full Version : Altec 19 wiring help



jkp2240
02-01-2004, 11:26 AM
Can someone please tell on a 19 if green/black is for woofer and red/black is for the horn from the crossover??

boputnam
02-01-2004, 11:42 AM
Hey... Welcome. :wave:

I don't know the Altec19, but do know the Altec Model Nine, which is GRN and BLK to the LF, and RED and WHT to the HF. "In the day", Altec and JBL seemed to use similar wiring colors/conventions, and JBL used GRN for the LF. I'd bet your GRN goes to the LF.

John
02-01-2004, 08:13 PM
I have just took a look thru the port on my 19,s and the red+black go to the H.F. and green+black to L.F.:yes: :yes:

SteveC
02-18-2004, 04:08 PM
Hello
You have probably solved the wiring issue for your altec 19's. You can determine the positive & negitive by inspecting the crossover. Look at where the wire connects to the xover and if you see a resistor or any other part connected to the leg it is the positive wire. If only the wire is connected to the leg, it is negitive. Here are a couple of pictures of some modle 19 crossovers that modified a couple months ago. The capacitors used are:
Jensen PIO & Solen. The resistors are mills non inductive wire wound.

SteveCrossover Pictures (http://www.geocities.com/atticoftreasures1/altec.html)

jkp2240
02-18-2004, 04:11 PM
Thanks for all the help to you and Great Plains Audio for reconing my 416's, they sound great!
John

SteveC
02-18-2004, 04:15 PM
Crossover Picture (fixed) (http://www.geocities.com/atticoftreasures1/altec.html)

jkp2240
02-18-2004, 04:16 PM
Your page link is not available