PDA

View Full Version : Tangerine Phase Plug Glue



miker
11-04-2006, 02:40 AM
I recently replaced the diaphragms in my Altec 902-8A's. On one of them, the tangerine phase plug is loose. It looks like it was glued to the magnet structure originally. When reassembled with the plug loose, it produces a distorted sound.

What should I use to glue this plug back in place?

Thanks.

Gary L
11-04-2006, 04:48 AM
I have seen this allot and think it is the result of the dissimilar materials used. Metal and plastic are affected differently with changes in temperature.
Clean the old glue off both the post and the plug and re glue with a very thin coat of two part epoxy. Carefull not to use too heavy a coat that it oozes into the slits or down into the gap.
You might also double over a piece of masking tape with sticky side out and use it to clean debris between the gap.
Keep your drivers in a temperature controlled area. I find loose tangerines almost always where speakers are stored in unheated garages or storage areas.

Gary

moldyoldy
11-04-2006, 06:37 AM
The plastic plug is the tricky bond, pretreating it with the proper solvent is the key to a good bond. The best such product available to consumers is Loctite Plastix, a cyanocrylate packaged with a separate plastic primer component.

For less-critical plastic bonding, PVC primer applied before any common super glue works well for the same reason, but I'd hesitate to try it on a tangerine (might melt it).

Obviously, any old glue residue must be removed, there's no tolerance for improper placement.

miker
11-05-2006, 05:27 AM
Thanks for the advice. Loctite Plastix is now sold under the name Loctite Super Glue - All Plastics. It seems to have done a nice job of bonding the plastic plug to the steel surface. I used paper shims in the voice coil gap to help center the plug. The distortion I was having is now gone.

Thanks.