PDA

View Full Version : L36s falling apart in the UK - what to do?



Formula400
10-29-2006, 01:27 PM
Hi, my name is Geoff and I come from England. I've been browsing this great forum and am now posting to seek help. I bought a new pair of JBL L36s in Florida when I was working there in the mid '70s. (5 years of heaven!).
They haven't had a lot of use over the past few years but have always sounded good. Recently I noticed that they didn't sound right in a new surround set-up. I investigated and found the following:
Bass is OK on both speakers, despite the foam falling apart. Both need a re-foam.
On one speaker, neither the mid or tweeter were producing any sound. On both the drivers the push on connections on the 'live' side were corroded. I removed the units from the enclosure and measured across them in situ; I saw a high resistance. I carefully removed the connections to the mid and tweeter and removed the corrosion on the terminals. Both units measured open circuit (not the expected 8 ohm). Physically, both drivers look fine.
On the other speaker, from listening, I believe the tweeter may also be open circuit. The mid is OK.

So, after the symptoms - my questions:
I'm sure the speakers haven't been mis-used, electrically or mechanically, so is it unusual for 30 year old drivers to go open circuit? Are they repairable? As I imagine that new replacement drivers are expensive, are used drivers (LE25-4 and LE56 (I think)) readily available?
Do you have any recommendations on whose re-foam kit to use?
Do you have any advice on who to contact in the UK?

My opportunities to refurbish these speakers in the UK may be limited, because I don't think JBL sold in large numbers over here. That would be a shame, because I do like the sound of these speakers in proper working condition.
I appreciate any help you can give me.

Geoff
still missing that Florida sunshine.

olympus
10-29-2006, 01:41 PM
hi geoff,im in epsom,quite close to you.try mike at acoustic on 020 8579 2872. phone is often busy but keep trying! cheers!